To jest tylko wersja do druku, aby zobaczyć pełną wersję tematu, kliknij TUTAJ
phpBB2 by Przemo
Support forów phpBB2 modified by Przemo

Ogłoszenia - Publikacja wersji 1.12.9

mek1942 - 02-09-2015, 18:56

widze że każdy ma głęboko .... wymienione przez nas błędy heh
Lord Darth - 03-09-2015, 11:16

MySQL: 5.1.63-0+squeeze1
PHP: 5.3.21

Po ponownym zainstalowaniu aktualizacji udało mi się pozbyć krzaczków, poza jednym miejscem.

Ale to już jakoś przeżyję.

Nie wiem, czy to dzięki temu tematowi: http://www.przemo.org/php...pic.php?t=62233 ale kolejna próba aktualizacja miała miejsce, po wykonaniu: "Przystosowanie skryptu forum oraz bazy dla kodowania latin2". A nic innego nie zmieniałem.

xlesiu - 03-09-2015, 19:05

Lord Darth, to wynika ze zmian w function_hierarchy.php jest tam następująca zmiana kodu z
Kod:
$topic_title = substr($topic_title, 0, intval($board_config['last_topic_title_length'])) . '...';
na
Kod:
$topic_title = htmlentities(substr(html_entity_decode($topic_title), 0, intval($board_config['last_topic_title_length']))) . '...';

Lord Darth - 03-09-2015, 20:45

Dzięki, działa. Dobrze by było wydać, w przyszłości, jakąś "łatkę" z opisanymi tu problemami i propozycjami.
MaTeK_ - 04-09-2015, 07:22

kAzek29 napisał/a:
Wygląda na to że nowa wersja została wydana na siłę żeby tylko była. Usuwanie dotychczasowych funkcjonalności powinno być opcjonalne (w osobnych plikach instrukcje) aby każdy mógł usunąć to czego nie używa a nie na siłę albo musisz mieć pojęcie o skrypcie i PHP aby nie usunąć tego co chcesz zostawić a tak albo pozbywasz się wszystkiego (mimo że z czegoś korzystasz) albo nie zaktualizujesz do nowej wersji. Moim zdaniem trochę to nieprzemyślane.


Nikomu nie dogodzisz. Najpierw się wszyscy żalą, że po co jest download, chat, galeria i inne pierdoły, a po usunięciu tego już są problemy, że to zostało usunięte...

Pogratulować postawy.

irekk - 04-09-2015, 07:47

Lord Darth napisał/a:
PHP: 5.3.21
PHP w tej wersji nie jest wspierane od roku. 5.4 straci wsparcie niebawem. To trochę jakby mieć pretensję o to że samochód na diesla nie działa ci z naftą, bo mercedes z '75, na niej jeździł ;)
Lord Darth - 04-09-2015, 08:35

Od roku też w sumie nic się nie działo. :) Ale za to "tryb zgodności" działa świetnie. Dopóki nie wyjdzie ten nowy skrypt, nie mam się co martwić o to, że PHP 5.3 nie podoła. :)

Swoją drogą, jeśli mówić o postępie, można by w "standardzie" oficjalnej paczki dodać lepsze zabezpieczenia anty botowe. To jest nawet niezłe: http://przemo.org/phpBB2/...ic.php?t=141457

bustersk - 04-09-2015, 09:47

MaTeK_ napisał/a:
kAzek29 napisał/a:
Wygląda na to że nowa wersja została wydana na siłę żeby tylko była. Usuwanie dotychczasowych funkcjonalności powinno być opcjonalne (w osobnych plikach instrukcje) aby każdy mógł usunąć to czego nie używa a nie na siłę albo musisz mieć pojęcie o skrypcie i PHP aby nie usunąć tego co chcesz zostawić a tak albo pozbywasz się wszystkiego (mimo że z czegoś korzystasz) albo nie zaktualizujesz do nowej wersji. Moim zdaniem trochę to nieprzemyślane.


Nikomu nie dogodzisz. Najpierw się wszyscy żalą, że po co jest download, chat, galeria i inne pierdoły, a po usunięciu tego już są problemy, że to zostało usunięte...

Pogratulować postawy.


już nie mówiąc o tym, że w pierwszym poście masz liste zmian i nikt nie każe aktualizować forum ;)

Lord Darth - 04-09-2015, 10:56

Jedyne, z czym bym polemizował, to usunięcie moda urodzinowego. Reszta faktycznie - nieprzydatna.
Lord Darth - 05-09-2015, 08:42

Po pewnym czasie zauważyłem inny błąd, który u mnie występuje. Po aktualizacji bazy danych, nowy użytkownik nie wyświetla się, jako ostatnio zarejestrowana osoba, a jego id w bazie wynosi 0.

Hmm... Miałem nadzieję, że scali posty automatycznie.

mek1942 - 08-09-2015, 14:53

no i cisza.......
ja nie wiem po co tą wersje wogóle wrzuciliscie na główną http://www.przemo.org/phpBB2/ skoro jest tyle błędów. Zamiast to szybko wycofać i poprawić błędy to widze ze wy macie wszystkich ludzi głęboko.

Nawet Przemo nie reaguje mimo iż to skrypt jet jakby pod jego szyldem, troche wstyd by mi było wypuszczać coś niegotowego.

Orbitex - 08-09-2015, 17:18

Kiedy będzie jakaś instrukcja aktualizacji szablonów z wersji 1.12.8 do 1.12.9?
asdf - 08-09-2015, 19:59

Będzie tydzień temu :) http://przemo.org/phpBB2/...ic.php?t=153558

A kiedy będzie instrukcja naprawy choćby jednego buga w wersji 1.12.9? :lol:

kooza - 08-09-2015, 20:00

Oo nawet nie zauwazylem ze nowa wersja ma az tyle pobran, super :roll:
Lord Darth - 09-09-2015, 16:16

Mogliby też dodać, na trwałe: <meta name="viewport" content="width=device-width, initial-scale=1.0"> Bez tego forum, na nowym skrypcie, nie otwiera się w przeglądarce "opera mini".


Powered by phpBB modified by Przemo © 2003 phpBB Group