To jest tylko wersja do druku, aby zobaczyć pełną wersję tematu, kliknij TUTAJ
phpBB2 by Przemo
Support forów phpBB2 modified by Przemo

F.A.Q. - Najczęściej Zadawane Pytania - Nie mo?na wys?a? posta na PHP 5.4

Woytec - 28-08-2013, 16:21
Temat postu: Nie można wysłać posta na PHP 5.4
Jeżeli po wysłaniu wiadomości nie zapisuje się i powraca cię do formularza wysyłania wiadomości to przyczyną może być wersja PHP. W wersjach większych niż PHP 5.4 funkcja htmlspecialchars, aby działała poprawnie z używanym przez nas kodowaniem (iso-8859-2) wymaga podania tego jako jej parametr (od tej wersji domyślnie jest to UTF-8 nieobsługiwane przez skrypt). Należy więc zastosować tę poprawkę, zamieniając wszystkie wystąpienia we wszystkich plikach htmlspecialchars na xhtmlspecialchars i umieścić deklarację nowej funkcji.
Oryginalny pomysł

Informacja dotyczy wersji mniejszych niż 1.12.8. Wersja 1.12.8 zawiera już tę poprawkę.

SeNioR - 31-10-2013, 20:44

http://przemo.org/phpBB2/...ic.php?t=149550

Tutaj jest dokładniejsza instrukcja + poprawka błędu który występuje na 5.4

Marek83 - 24-10-2015, 11:47

Dzień dobry

Co jeśli mam 12.8, a hostingodawca zmienił php z 5.2 na 5.5 i nie można właśnie pisać postów?

Pozdrawiam

Woytec - 25-10-2015, 14:16

Marek83 napisał/a:
Dzień dobry

Co jeśli mam 12.8, a hostingodawca zmienił php z 5.2 na 5.5 i nie można właśnie pisać postów?

Pozdrawiam
Czy objawia się to tym samym? Adres?
Marek83 - 30-10-2015, 06:54

Powróciłem do korzystania ze starej wersji php poprzez dodanie jednej linijki w htaccess. Pozdrawiam


Powered by phpBB modified by Przemo © 2003 phpBB Group